aboutsummaryrefslogtreecommitdiffstats
path: root/matchbox/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'matchbox/Makefile.am')
-rw-r--r--matchbox/Makefile.am101
1 files changed, 101 insertions, 0 deletions
diff --git a/matchbox/Makefile.am b/matchbox/Makefile.am
new file mode 100644
index 0000000..b0098f6
--- /dev/null
+++ b/matchbox/Makefile.am
@@ -0,0 +1,101 @@
+
+lib_LTLIBRARIES = libmatchbox-@MBWM_API_VERSION@.la
+
+source_public_h = \
+ matchbox.h
+
+# Core...
+source = \
+ mb-wm-types.h \
+ mb-wm-macros.h \
+ mb-wm-object.h \
+ mb-wm-object-props.h \
+ mb-wm-object.c \
+ mb-wm-debug.h \
+ mb-wm-debug.c \
+ mb-wm-client.h \
+ mb-wm-client.c \
+ mb-wm-client-base.h \
+ mb-wm-client-base.c \
+ mb-wm-client-window.h \
+ mb-wm-client-window.c \
+ mb-wm-root-window.h \
+ mb-wm-root-window.c \
+ mb-wm-stack.h \
+ mb-wm-stack.c \
+ mb-wm-props.h \
+ mb-wm-props.c \
+ mb-wm-util.h \
+ mb-wm-util.c \
+ mb-wm-atoms.h \
+ mb-wm-atoms.c \
+ mb-wm-layout.h \
+ mb-wm-layout.c \
+ mb-wm-keys.h \
+ mb-wm-keys.c \
+ mb-wm-decor.h \
+ mb-wm-decor.c \
+ mb-window-manager.h \
+ mb-window-manager.c \
+ mb-wm-main-context.h \
+ mb-wm-main-context.c \
+ xas.h \
+ xas.c
+
+# Client window types...
+source += \
+ mb-wm-client-app.h \
+ mb-wm-client-app.c \
+ mb-wm-client-panel.h \
+ mb-wm-client-panel.c \
+ mb-wm-client-dialog.h \
+ mb-wm-client-dialog.c \
+ mb-wm-client-note.h \
+ mb-wm-client-note.c \
+ mb-wm-client-input.h \
+ mb-wm-client-input.c \
+ mb-wm-client-desktop.h \
+ mb-wm-client-desktop.c \
+ mb-wm-client-menu.h \
+ mb-wm-client-menu.c \
+ mb-wm-client-override.h \
+ mb-wm-client-override.c
+
+
+# Compositing...
+if ENABLE_COMPOSITE
+source += mb-wm-comp-mgr.h
+source += mb-wm-comp-mgr.c
+
+if COMP_MGR_BACKEND
+if ENABLE_CLUTTER_COMPOSITE_MANAGER
+source += mb-wm-comp-mgr-clutter.h
+source += mb-wm-comp-mgr-clutter.c
+source += tidy/tidy-texture-frame.h
+source += tidy/tidy-texture-frame.c
+else
+source += mb-wm-comp-mgr-xrender.h
+source += mb-wm-comp-mgr-xrender.c
+endif
+endif
+
+endif #ENABLE_COMPOSITE
+
+# Theming...
+source += \
+ mb-wm-theme.h \
+ mb-wm-theme.c \
+ mb-wm-theme-xml.h \
+ mb-wm-theme-xml.c
+
+if THEME_PNG
+source += mb-wm-theme-png.c mb-wm-theme-png.h
+endif
+
+pkgincludedir = $(includedir)/matchbox-$(MBWM_API_VERSION)/matchbox
+pkginclude_HEADERS = $(source_public_h)
+
+libmatchbox_@MBWM_API_VERSION@_la_SOURCES = $(source_public_h) $(source)
+libmatchbox_@MBWM_API_VERSION@_la_CFLAGS = $(MBWM_INCS) $(MBWM_CFLAGS) -DDATADIR=\"$(datadir)\"
+libmatchbox_@MBWM_API_VERSION@_la_LIBADD = $(MBWM_LIBS)
+