aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 0 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index d814d44..3ca9697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,18 +62,10 @@ AC_ARG_WITH(pango,
[ --with-pango Use of pango for text layout],
[use_pango=$withval], [use_pango=no])
-AC_ARG_WITH(gtk,
- [ --with-gtk With GTK integration support],
- [use_gtk=$withval], [use_gtk=no])
-
AC_ARG_ENABLE(compositing,
[ --enable-compositing Enable support for compositing],
[compositing=$enableval], [compositing=no])
-AC_ARG_ENABLE(glib-main-loop,
- [ --enable-glib-main-loop Enable use of glib main loop],
- [gmloop=$enableval], [gmloop=no])
-
AC_ARG_ENABLE(matchbox-remote,
[ --enable-matchbox-remote Enable matchbox remote control utility],
[matchbox_remote=$enableval], [matchbox_remote=no])
@@ -99,10 +91,6 @@ if ! test "x$use_pango" = "xyes" -o "x$use_pango" = "xyes"; then
needed_pkgs="$needed_pkgs xft "
fi
-if test "x$use_gtk" = "xyes"; then
- needed_pkgs="$needed_pkgs gtk+-2.0 "
-fi
-
if test "x$png_theme" = "xyes"; then
needed_pkgs="$needed_pkgs libpng12 "
fi
@@ -137,7 +125,6 @@ for manager in $included_managers; do
;;
clutter )
needed_pkgs="$needed_pkgs $clutter_package xcomposite xdamage "
- gmloop="yes"
;;
esac
@@ -157,12 +144,6 @@ if test "x$want_debug" = "xyes"; then
fi
AC_SUBST(MBWM_WANT_DEBUG)
-USE_GLIB_MAINLOOP=0
-if test "x$gmloop" = "xyes"; then
- USE_GLIB_MAINLOOP=1
-fi
-AC_SUBST(USE_GLIB_MAINLOOP)
-
USE_PANGO=0
if test "$use_pango" = yes; then
USE_PANGO=1
@@ -184,13 +165,6 @@ if test "$use_png" != yes; then
fi
AC_SUBST(THEME_SIMPLE)
-USE_GTK=0
-AM_CONDITIONAL(USE_GTK, test "x$use_gtk" = "xyes")
-if test "$use_gtk" = yes; then
- USE_GTK=1
-fi
-AC_SUBST(USE_GTK)
-
PKG_CHECK_MODULES(MBWM, $needed_pkgs)
MBWM_PKGREQUIRES="$MBWM_PKGREQUIRES $needed_pkgs"
AC_SUBST(MBWM_PKGREQUIRES)
@@ -311,7 +285,6 @@ echo "
Themes:
PNG theme : ${png_theme}
- GTK integration : ${use_gtk}
Pango integration : ${use_pango}
Managers:
@@ -321,7 +294,6 @@ echo "
Miscel:
Compositing support : ${compositing}
- Glib main loop : ${gmloop}
Build matchbox-remote : ${matchbox_remote}
Debugging output : ${want_debug}
"