aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 26 insertions, 40 deletions
diff --git a/configure.ac b/configure.ac
index 8495912..90f9160 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,34 +1,28 @@
-# mbwm2 package version number, (as distinct from shared library version)
-# An odd minor number indicates in-progress development, (eg. from svn)
+# mbwm package version number, (as distinct from shared library version)
+# An odd minor number indicates in-progress development, (eg. from Git)
# An even minor number indicates a released version.
-m4_define([mbwm2_major_version], [0])
-m4_define([mbwm2_minor_version], [1])
-m4_define([mbwm2_micro_version], [0])
+m4_define([mbwm_major_version], [1])
+m4_define([mbwm_minor_version], [9999])
+m4_define([mbwm_micro_version], [0])
-m4_define([mbwm2_version],
- [mbwm2_major_version.mbwm2_minor_version.mbwm2_micro_version])
+m4_define([mbwm_version],
+ [mbwm_major_version.mbwm_minor_version.mbwm_micro_version])
-m4_define([mbwm2_api_version],
- [mbwm2_major_version.mbwm2_minor_version])
+# Change this only when breaking the API
+m4_define([mbwm_api_version], [2.0])
AC_PREREQ(2.63)
-AC_INIT([matchbox-window-manager-2], mbwm2_version, [mallum@handhelds.org])
-AC_CONFIG_SRCDIR([matchbox2/mb-window-manager.c])
+AC_INIT([matchbox], mbwm_version, [mallum@handhelds.org])
+AC_CONFIG_SRCDIR([matchbox/mb-window-manager.c])
AM_INIT_AUTOMAKE(1.11 foreign dist-bzip2)
AM_SILENT_RULES([yes])
-MBWM2_VERSION=mbwm2_version
-AC_SUBST(MBWM2_VERSION)
+MBWM_VERSION=mbwm_version
+AC_SUBST(MBWM_VERSION)
-MBWM2_API_VERSION=mbwm2_api_version
-AC_SUBST(MBWM2_API_VERSION)
-
-MBWM2_INCDIR=matchbox-wm-2/$MBWM2_API_VERSION/matchbox
-AC_SUBST(MBWM2_INCDIR)
-
-MBWM2_PKGINCDIR=matchbox-wm-2/$MBWM2_API_VERSION/
-AC_SUBST(MBWM2_PKGINCDIR)
+MBWM_API_VERSION=mbwm_api_version
+AC_SUBST(MBWM_API_VERSION)
clutter_package="clutter-1.0 >= 1.5.6"
@@ -206,8 +200,8 @@ fi
AC_SUBST(USE_GTK)
PKG_CHECK_MODULES(MBWM, $needed_pkgs)
-MBWM2_PKGREQUIRES="$MBWM2_PKGREQUIRES $needed_pkgs"
-AC_SUBST(MBWM2_PKGREQUIRES)
+MBWM_PKGREQUIRES="$MBWM_PKGREQUIRES $needed_pkgs"
+AC_SUBST(MBWM_PKGREQUIRES)
COMP_MGR_BACKEND=0
ENABLE_COMPOSITE=0
@@ -249,7 +243,7 @@ AC_ARG_ENABLE(simple-manager,
[ --disable-simple-manager Do not build simple window manager],
[simple_manager=$enableval],
[
- if test "x$libmatchbox2" = "xyes"; then
+ if test "x$libmatchbox" = "xyes"; then
simple_manager=no
else
simple_manager=yes
@@ -273,14 +267,14 @@ PKG_CHECK_MODULES(XFIXES, xfixes >= 4.0, have_xfixes=yes, have_xfixes=no)
if test x$have_xfixes = xyes; then
AC_DEFINE(HAVE_XFIXES, [1], [Use XFixes ext to really hide cursor])
- MBWM2_PKGREQUIRES="$MBWM2_PKGREQUIRES xfixes >= 0.4"
+ MBWM_PKGREQUIRES="$MBWM_PKGREQUIRES xfixes >= 0.4"
fi
PKG_CHECK_MODULES(XEXT, xext, have_xext=yes, have_xext=no)
if test x$have_xext = xyes; then
AC_DEFINE(HAVE_XEXT, [1], [Use Xext ext])
- MBWM2_PKGREQUIRES="$MBWM2_PKGREQUIRES xext"
+ MBWM_PKGREQUIRES="$MBWM_PKGREQUIRES xext"
fi
PKG_CHECK_MODULES(XCURSOR, xcursor, have_xcursor=yes, have_xcursor=no)
@@ -289,28 +283,21 @@ if test x$have_xcursor = xyes; then
AC_DEFINE(HAVE_XCURSOR, [1], [Use XCursor to sync pointer themes])
fi
-MBWM_INCS='-I$(top_srcdir) -I$(top_srcdir)/matchbox2/core -I$(top_srcdir)/matchbox2/client-types -I$(top_srcdir)/matchbox2/theme-engines -I$(top_srcdir)/matchbox2/comp-mgr -I$(top_builddir)'
-MBWM_CORE_LIB='$(top_builddir)/matchbox2/core/libmatchbox-window-manager-2-core.la'
-MBWM_CLIENT_BUILDDIR='$(top_builddir)/matchbox2/client-types'
-MBWM_THEME_BUILDDIR='$(top_builddir)/matchbox2/theme-engines'
-MBWM_COMPMGR_BUILDDIR='$(top_builddir)/matchbox2/comp-mgr'
+MBWM_INCS='-I$(top_srcdir) -I$(top_srcdir)/matchbox -I$(top_builddir)'
MBWM_CFLAGS="$MBWM_CFLAGS $MBWM_DEBUG_CFLAGS $XFIXES_CFLAGS $XEXT_CFLAGS $XCURSOR_CFLAGS"
MBWM_LIBS="$MBWM_LIBS $XFIXES_LIBS $XEXT_LIBS $XCURSOR_LIBS $MBWM_EXTRA_LIBS"
AC_SUBST([MBWM_CFLAGS])
AC_SUBST([MBWM_LIBS])
-AC_SUBST([MBWM_CORE_LIB])
AC_SUBST([MBWM_INCS])
-AC_SUBST([MBWM_CLIENT_BUILDDIR])
-AC_SUBST([MBWM_THEME_BUILDDIR])
-AC_SUBST([MBWM_COMPMGR_BUILDDIR])
AC_SUBST([MBWM_DEBUG_CFLAGS])
AC_SUBST([MBWM_DEBUG_LDFLAGS])
AC_OUTPUT([
Makefile
-matchbox2/Makefile
-matchbox2/mb-wm-config.h
+matchbox-$MBWM_API_VERSION.pc:matchbox.pc.in
+matchbox/Makefile
+matchbox/mb-wm-config.h
managers/Makefile
managers/simple/Makefile
managers/maemo/Makefile
@@ -319,11 +306,10 @@ data/Makefile
data/themes/Makefile
data/themes/Default/Makefile
data/themes/PngSample/Makefile
-data/libmatchbox2.pc
doc/Makefile
doc/reference/Makefile
-doc/reference/matchbox2/Makefile
-doc/reference/matchbox2/version.xml
+doc/reference/matchbox/Makefile
+doc/reference/matchbox/version.xml
util/Makefile
])