aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e86909f..3280c94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,10 +148,13 @@ IFS="$save_ifs"
AC_SUBST(COMPOSITE_MANAGER_DEFINE)
+MBWM_WANT_DEBUG=0
if test "x$want_debug" = "xyes"; then
- MBWM_DEBUG_CFLAGS="-O0 $MBWM_DEBUG_CFLAGS -DMBWM_WANT_DEBUG"
+ MBWM_WANT_DEBUG=1
+ MBWM_DEBUG_CFLAGS="-O0 $MBWM_DEBUG_CFLAGS"
MBWM_DEBUG_LDFLAGS="$MBWM_DEBUG_LDFLAGS -rdynamic"
fi
+AC_SUBST(MBWM_WANT_DEBUG)
USE_GLIB_MAINLOOP=0
if test "x$gmloop" = "xyes"; then