aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ccf094a..9e839db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,9 @@ AC_CONFIG_SRCDIR([matchbox2/core/mb-window-manager.c])
AM_INIT_AUTOMAKE()
+MBWM2_VERSION=mbwm2_version
+AC_SUBST(MBWM2_VERSION)
+
MBWM2_API_VERSION=mbwm2_api_version
AC_SUBST(MBWM2_API_VERSION)
@@ -38,6 +41,18 @@ AC_CHECK_HEADERS([stdlib.h string.h expat.h])
AC_C_CONST
AC_CHECK_FUNCS([memset strdup strncasecmp])
+GTK_DOC_CHECK([1.13], [--flavour no-tmpl])
+
+# we don't want to build the documentation from a Git clone unless we
+# explicitly tell configure to do so; this allows avoiding to recurse into
+# the documentation directory when building Matchbox2 inside Poky for a
+# target device that doesn't have gtk-doc installed. for reference
+# see: http://bugzilla.openedhand.com/show_bug.cgi?id=1047
+#
+# we use autogen.sh as it exists only inside the Git clones, and it
+# is not packaged into tarballs.
+AM_CONDITIONAL([BUILD_GTK_DOC], [test "x$enable_gtk_doc" = "xyes" || test ! -f "autogen.sh"])
+
needed_pkgs="x11 "
AC_ARG_ENABLE(debug,
@@ -315,6 +330,9 @@ data/themes/Default/Makefile
data/themes/PngSample/Makefile
data/libmatchbox2.pc
doc/Makefile
+doc/reference/Makefile
+doc/reference/matchbox2/Makefile
+doc/reference/matchbox2/version.xml
util/Makefile
])
@@ -326,6 +344,9 @@ echo "
source code location: ${srcdir}
install prefix : ${prefix}
+ Documentation:
+ Build API Reference : ${enable_gtk_doc}
+
Extension:
Xfixes : ${have_xfixes}
Xext : ${have_xext}