aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ee288f2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+INCLUDES = $(GTK_CFLAGS) $(DEVELOPMENT_CFLAGS)
+
+enginedir = $(libdir)/gtk-2.0/$(GTK_VERSION)/engines
+
+engine_LTLIBRARIES = libpoky-engine.la
+
+libpoky_engine_la_SOURCES = \
+ ./src/poky-draw.c \
+ ./src/poky-draw.h \
+ ./src/poky-main.c \
+ ./src/poky-style.c \
+ ./src/poky-style.h
+
+libpoky_engine_la_LDFLAGS = -module -avoid-version -no-undefined
+libpoky_engine_la_LIBADD = $(GTK_LIBS)
+
+
+
+themedir = $(datadir)/themes/Poky/gtk-2.0
+theme_DATA = data/gtkrc
+
+EXTRA_DIST = $(theme_DATA)