summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b610529..ebe4af6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,7 +1,8 @@
-AM_CFLAGS = @GCC_FLAGS@
+AM_CFLAGS = @GCC_FLAGS@
noinst_PROGRAMS= test-fb \
test-gdk \
+ test-gdk-idle \
test-gtk-layout \
test-pango-layout \
test-x \
@@ -20,6 +21,11 @@ test_gdk_SOURCES = test-gdk.c
test_gdk_LDADD = @GTK_LIBS@
test_gdk_CFLAGS = @GTK_CFLAGS@
+# fullscreen blit to gtk drawing area via gtk pixbufs in an idle handler
+test_gdk_idle_SOURCES = test-gdk-idle.c
+test_gdk_idle_LDADD = @GTK_LIBS@
+test_gdk_idle_CFLAGS = @GTK_CFLAGS@
+
# fullscreen blit to x window via shm
test_x_SOURCES = test-x.c
test_x_LDADD = @XLIBS_LIBS@