summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
index 055f73d515..3ac81ef05f 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.1.0.bb
@@ -9,7 +9,7 @@ LICENSE = "MIT & PD"
LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
-DEPENDS = "virtual/libx11 virtual/libgl glew"
+DEPENDS = "virtual/libgl glew"
SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
file://glut.patch \
@@ -21,4 +21,20 @@ SRC_URI[sha256sum] = "9703fa0646b32a1e68d2abf5628f936f77bf97c69ffcaac90de380820a
inherit autotools pkgconfig
-EXTRA_OECONF = "--without-glut"
+PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
+ ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+
+# The Wayland code doesn't work with Wayland 1.0, so disable it for now
+#${@base_contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
+
+PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
+PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
+PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
+PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
+PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
+PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
+PACKAGECONFIG[glut] = "--with-glut,--without-glut,"
+PACKAGECONFIG[osmesa] = "--enable-libosmesa,--disable-libosmesa,"
+PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libvg"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
+PACKAGECONFIG[x11] = "--enable-libx11,--disable-libx11,virtual/libx11"