summaryrefslogtreecommitdiffstats
path: root/meta/conf
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-20 17:13:43 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-20 17:13:43 +0000
commit4398b980ba11f6a76f6c863f67f174cf1dc2bef6 (patch)
treeef35bc5c6f898f654d942f972146b3b2161f3f30 /meta/conf
parent173b999d9585d61890bdabc4d26a784bc7758ec4 (diff)
downloadpoky-4398b980ba11f6a76f6c863f67f174cf1dc2bef6.tar.gz
poky-4398b980ba11f6a76f6c863f67f174cf1dc2bef6.tar.bz2
poky-4398b980ba11f6a76f6c863f67f174cf1dc2bef6.zip
conf: Sync with OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@892 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/conf')
-rw-r--r--meta/conf/bitbake.conf11
-rw-r--r--meta/conf/distro/angstrom-2007.1.conf171
-rw-r--r--meta/conf/distro/include/angstrom.inc42
-rw-r--r--meta/conf/distro/include/maemo-preferred.inc10
-rw-r--r--meta/conf/distro/include/openzaurus.inc2
-rw-r--r--meta/conf/distro/include/preferred-gpe-versions-2.7.inc6
-rw-r--r--meta/conf/distro/include/preferred-opie-versions.inc2
-rw-r--r--meta/conf/distro/include/sane-srcdates.inc15
-rw-r--r--meta/conf/distro/openzaurus-unstable.conf14
-rw-r--r--meta/conf/distro/poky.conf13
-rw-r--r--meta/conf/documentation.conf4
-rw-r--r--meta/conf/machine/akita.conf2
-rw-r--r--meta/conf/machine/c7x0.conf2
-rw-r--r--meta/conf/machine/include/ixp4xx.conf20
-rw-r--r--meta/conf/machine/include/poodle-2.6.conf2
-rw-r--r--meta/conf/machine/include/qemu.conf1
-rw-r--r--meta/conf/machine/include/tosa-2.6.conf2
-rw-r--r--meta/conf/machine/include/tune-arm920t.conf2
-rw-r--r--meta/conf/machine/include/tune-arm9tdmi.conf1
-rw-r--r--meta/conf/machine/include/tune-iwmmxt.conf2
-rw-r--r--meta/conf/machine/include/zaurus-2.6.conf (renamed from meta/conf/machine/include/zaurus-clamshell-2.6.conf)10
-rw-r--r--meta/conf/machine/nokia770.conf4
-rw-r--r--meta/conf/machine/spitz.conf2
-rw-r--r--meta/conf/sanity.conf2
24 files changed, 187 insertions, 155 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index 2af2abe24d..d639e27b17 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -125,9 +125,9 @@ FILES_${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la \
/lib/*.a /lib/*.o ${datadir}/aclocal"
# RRECOMMENDS_${PN}-dbg = "${PN} (>= ${PV})"
RRECOMMENDS_${PN}-dbg = "${@['', '${PN} (>= ${PV})'][packaged(bb.data.getVar('PN', d, 1), d) == True]}"
+FILES_${PN}-locale = "${datadir}/locale"
FILES_${PN}-dbg = "${bindir}/.debug ${sbindir}/.debug ${libexecdir}/.debug ${libdir}/.debug \
/bin/.debug /sbin/.debug /lib/.debug ${libdir}/${PN}/.debug"
-FILES_${PN}-locale = "${datadir}/locale"
# File manifest
@@ -161,6 +161,7 @@ STAGING_LIBDIR = "${STAGING_DIR}/${HOST_SYS}/lib"
STAGING_INCDIR = "${STAGING_DIR}/${HOST_SYS}/include"
STAGING_DATADIR = "${STAGING_DIR}/${HOST_SYS}/share"
STAGING_LOADER_DIR = "${STAGING_DIR}/${HOST_SYS}/loader"
+STAGING_FIRMWARE_DIR = "${STAGING_DIR}/${HOST_SYS}/firmware"
STAGING_PYDIR = "${STAGING_DIR}/lib/python2.4"
DEPLOY_DIR = "${TMPDIR}/deploy"
@@ -193,12 +194,14 @@ IMAGE_CMD_cramfs = "mkcramfs ${IMAGE_ROOTFS} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.r
IMAGE_CMD_ext2 = "genext2fs -b ${IMAGE_ROOTFS_SIZE} -d ${IMAGE_ROOTFS} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext2 ${EXTRA_IMAGECMD}"
IMAGE_CMD_ext2.gz = "mkdir ${DEPLOY_DIR_IMAGE}/tmp.gz; genext2fs -b ${IMAGE_ROOTFS_SIZE} -d ${IMAGE_ROOTFS} ${DEPLOY_DIR_IMAGE}/tmp.gz/${IMAGE_NAME}.rootfs.ext2 ${EXTRA_IMAGECMD}; gzip -f -9 ${DEPLOY_DIR_IMAGE}/tmp.gz/${IMAGE_NAME}.rootfs.ext2; mv ${DEPLOY_DIR_IMAGE}/tmp.gz/${IMAGE_NAME}.rootfs.ext2.gz ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ext2.gz; rmdir ${DEPLOY_DIR_IMAGE}/tmp.gz"
IMAGE_CMD_squashfs = "mksquashfs ${IMAGE_ROOTFS} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.squashfs ${EXTRA_IMAGECMD} -noappend"
+IMAGE_CMD_squashfs-lzma = "mksquashfs-lzma ${IMAGE_ROOTFS} ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.squashfs-lzma ${EXTRA_IMAGECMD} -noappend"
IMAGE_CMD_tar = "cd ${IMAGE_ROOTFS} && tar -jcvf ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.tar.bz2 ."
IMAGE_CMD_tar.gz = "cd ${IMAGE_ROOTFS} && tar -zcvf ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.tar.gz ."
IMAGE_CMD_tar.bz2 = "cd ${IMAGE_ROOTFS} && tar -jcvf ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.tar.bz2 ."
EXTRA_IMAGECMD = ""
EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x40000"
EXTRA_IMAGECMD_squashfs = "-le -b 16384"
+EXTRA_IMAGECMD_squashfs-lzma = "-le -b 16384"
IMAGE_DEPENDS = ""
IMAGE_DEPENDS_jffs2 = "mtd-utils-native"
@@ -206,6 +209,7 @@ IMAGE_DEPENDS_cramfs = "cramfs-native"
IMAGE_DEPENDS_ext2 = "genext2fs-native"
IMAGE_DEPENDS_ext2.gz = "genext2fs-native"
IMAGE_DEPENDS_squashfs = "squashfs-tools-native"
+IMAGE_DEPENDS_squashfs-lzma = "squashfs-lzma-tools-native"
EXTRA_IMAGEDEPENDS = ""
##################################################################
@@ -316,7 +320,8 @@ export palmqtdir = "/opt/QtPalmtop"
GNU_MIRROR = "ftp://ftp.gnu.org/gnu"
DEBIAN_MIRROR = "ftp://ftp.debian.org/debian/pool"
SOURCEFORGE_MIRROR = "http://heanet.dl.sourceforge.net/sourceforge"
-GPE_MIRROR = "http://handhelds.org/pub/projects/gpe/source"
+GPE_MIRROR = "http://gpe.linuxtogo.org/download/source"
+GPE_SVN = "svn://projects.linuxtogo.org/svn/gpe/trunk/base;module=${PN}"
XLIBS_MIRROR = "http://xlibs.freedesktop.org/release"
XORG_MIRROR = "http://xorg.freedesktop.org/releases"
GNOME_MIRROR = "http://ftp.gnome.org/pub/GNOME/sources"
@@ -357,7 +362,7 @@ MKTEMPCMD = "mktemp -q ${TMPBASE}"
# a RCS, which freaks out those special folks with active Perforce clients
# the following makes patch ignore RCS:
-export PATCH_GET=0
+export PATCH_GET="0"
# Program to be used to build ipkg packages
diff --git a/meta/conf/distro/angstrom-2007.1.conf b/meta/conf/distro/angstrom-2007.1.conf
index 327d4123cc..f593194ba6 100644
--- a/meta/conf/distro/angstrom-2007.1.conf
+++ b/meta/conf/distro/angstrom-2007.1.conf
@@ -6,52 +6,87 @@
#@MAINTAINER: Michael 'Mickey' Lauer <mickey@Vanille.de>
#@--------------------------------------------------------------------
-#DISTRO_VERSION = "2006.9"
+#DISTRO_VERSION = "2007.1"
DISTRO_VERSION = "test-${DATE}"
+DISTRO_REVISION = "10"
require conf/distro/include/angstrom.inc
require conf/distro/include/sane-srcdates.inc
DISTRO_TYPE = "debug"
#DISTRO_TYPE = "release"
-#!!!!! DON'T FORGET TO ENABLE ZAPROOTPASSWD !!!!!
+#Set the right arch for the feeds
+#Alphabetically sorted
+
+FEED_ARCH ?= "${TARGET_ARCH}"
+
+#armv4t machines
+
+FEED_ARCH_ep93xx = "armv4t"
+FEED_ARCH_h6300 = "armv4t"
+
+#armv5t machines
+
+FEED_ARCH_a780 = "armv5te"
+FEED_ARCH_akita = "armv5te"
+FEED_ARCH_c7x0 = "armv5te"
+FEED_ARCH_h2200 = "armv5te"
+FEED_ARCH_h4000 = "armv5te"
+FEED_ARCH_h5xxx = "armv5te"
+FEED_ARCH_htcuniversal = "armv5te"
+FEED_ARCH_hx2000 = "armv5te"
+FEED_ARCH_hx4700 = "armv5te"
+FEED_ARCH_ixp4xx = "armv5te"
+FEED_ARCH_magician = "armv5te"
+FEED_ARCH_netbook-pro = "armv5te"
+FEED_ARCH_nokia770 = "armv5te"
+FEED_ARCH_poodle = "armv5te"
+FEED_ARCH_spitz = "armv5te"
+FEED_ARCH_tosa = "armv5te"
+
+#i686 machines
+
+FEED_ARCH_guinness = "i686"
FEED_URIS += " \
- base##${ANGSTROM_URI}/unstable/feed/base \
- perl##${ANGSTROM_URI}/unstable/feed/perl \
- python##${ANGSTROM_URI}/unstable/feed/python \
- debug##${ANGSTROM_URI}/unstable/feed/debug \
- ${MACHINE}##${ANGSTROM_URI}/unstable/feed/machine/${MACHINE}"
-# base##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/base \
-# ${MACHINE}##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/${MACHINE} \
-# updates##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/updates"
-
-#SRCDATE = "20060630"
-#SRCDATE_handhelds-pxa-2.6 = "20060622"
+ no-arch##${ANGSTROM_URI}/unstable/feed/all \
+ base##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/base \
+ perl##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/perl \
+ python##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/python \
+ debug##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/debug \
+ ${MACHINE}##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/machine/${MACHINE}"
+# base##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/${FEED_ARCH}/base \
+# ${MACHINE}##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/${FEED_ARCH}/machine/${MACHINE} \
+# updates##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/${FEED_ARCH}/updates"
+
+
+# We will lock down a SRCDATE when we go into release mode
+#SRCDATE = "20061029"
+
+PREFERRED_VERSION_linux-handhelds-2.6 = "2.6.16-hh7"
+PREFERRED_VERSION_linux-handhelds-2.6_htcuniversal = "2.6.17-hh2"
+
+
SRCDATE_gconf-dbus = "20060719"
SRCDATE_gnome-vfs-dbus = "20060803"
-PREFERRED_VERSION_qemu-native = "0.8.2"
-
CVS_TARBALL_STASH = "\
http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/sources/ \
-http://www.oesources.org/source/current/"
-
-# Opie
-#use 1337 mt version of opie to have a webbrowser
-PALMTOP_USE_MULTITHREADED_QT = "yes"
-QTE_VERSION = "2.3.10"
-OPIE_VERSION = "1.2.2"
-require conf/distro/include/preferred-opie-versions.inc
+"
# GPE
require conf/distro/include/preferred-gpe-versions-2.8.inc
PREFERRED_PROVIDER_dbus-glib = "dbus-glib"
+PREFERRED_PROVIDER_virtual/libsdl ?= "libsdl-x11"
+PREFERRED_PROVIDER_virtual/libxine ?= "libxine-x11"
+
PREFERRED_VERSION_fontconfig = "2.3.95"
PREFERRED_VERSION_freetype = "2.2.1"
+#fix screen corruption issues
+PREFERRED_VERSION_cairo = "1.3.2"
#Small machines prefer kdrive, but we might ship full Xorg in other images
PREFERRED_PROVIDER_virtual/xserver ?= "xserver-kdrive"
@@ -59,7 +94,8 @@ PREFERRED_PROVIDER_xserver ?= "xserver-kdrive"
require conf/distro/include/preferred-xorg-versions-X11R7.1.inc
-PREFERRED_VERSION_xserver-kdrive = "1.1.0+git${SRCDATE}"
+PREFERRED_VERSION_xserver-kdrive = "X11R7.1-1.1.0"
+PREFERRED_VERSION_gtk+ = "2.10.6"
#zap extra stuff taking place in $MACHINE.conf
GPE_EXTRA_INSTALL = ""
@@ -78,41 +114,49 @@ PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}gcc:gcc-cross"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}g++:gcc-cross"
-# Libc/uclibc:
-#fix some iconv issues, needs to be adjusted when doing uclibc builds
-PREFERRED_PROVIDER_virtual/libiconv ?= glibc
-PREFERRED_PROVIDER_virtual/libintl ?= glibc
-
# Virtuals:
PREFERRED_PROVIDER_virtual/db ?= "db"
PREFERRED_PROVIDER_virtual/db-native ?= "db-native"
-PREFERRED_PROVIDER_virtual/xserver ?= xserver-kdrive
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-kdrive"
# Others:
PREFERRED_PROVIDER_virtual/libx11 ?= "diet-x11"
-PREFERRED_PROVIDER_gconf ?= gconf-dbus
-PREFERRED_PROVIDER_gnome-vfs ?= gnome-vfs
-PREFERRED_PROVIDER_tslib ?= tslib
+PREFERRED_PROVIDER_gconf ?= "gconf-dbus"
+PREFERRED_PROVIDER_gnome-vfs ?= "gnome-vfs"
+PREFERRED_PROVIDER_tslib ?= "tslib"
+PREFERRED_PROVIDER_tslib-conf ?= "tslib"
PREFERRED_PROVIDER_libgpewidget ?= "libgpewidget"
PREFERRED_PROVIDER_ntp = "ntp"
PREFERRED_PROVIDER_hotplug = "udev"
PREFERRED_PROVIDER_libxss = "libxss"
+#Machine related toolchain stuff
+ARCH_BYTE_SEX_ixp4xx = "le"
+
+
#EABI stuff
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}-libc-for-gcc = "glibc-intermediate"
PREFERRED_PROVIDER_virtual/arm-angstrom-linux-gnueabi-libc-for-gcc = "glibc-intermediate"
PREFERRED_PROVIDER_virtual/arm-linux-libc-for-gcc = "glibc-intermediate"
+#shouldn't that be uclibc-initial????
+PREFERRED_PROVIDER_virtual/arm-angstrom-linux-uclibcgnueabi-libc-for-gcc = "uclibc-initial"
#use EABI toolchain
PREFERRED_VERSION_gcc ?= "4.1.1"
PREFERRED_VERSION_gcc-cross ?= "4.1.1"
+PREFERRED_VERSION_gcc-cross-sdk ?= "4.1.1"
PREFERRED_VERSION_gcc-cross-initial ?= "4.1.1"
-PREFERRED_VERSION_binutils ?= "2.17"
-PREFERRED_VERSION_binutils-cross ?= "2.17"
+
+PREFERRED_VERSION_binutils ?= "2.17.50.0.5"
+PREFERRED_VERSION_binutils-cross ?= "2.17.50.0.5"
+PREFERRED_VERSION_binutils-cross-sdk ?= "2.17.50.0.5"
+
+PREFERRED_VERSION_linux-libc-headers_guinness ?= "2.6.18"
PREFERRED_VERSION_linux-libc-headers ?= "2.6.15.99"
-PREFERRED_VERSION_glibc ?= "2.4"
-PREFERRED_VERSION_glibc-intermediate ?= "2.4"
+
+PREFERRED_VERSION_glibc ?= "2.5"
+PREFERRED_VERSION_glibc-intermediate ?= "2.5"
# To use an EABI compatible version 3 series gcc, either uncomment
# the lines below or set them in local.conf:
@@ -126,29 +170,21 @@ PREFERRED_VERSION_busybox = "1.2.1"
PREFERRED_VERSION_orinoco-modules_h3600 = "0.13e"
PREFERRED_VERSION_orinoco-modules_h3900 = "0.13e"
-PREFERRED_VERSION_dbus ?= "0.92"
+
+PREFERRED_VERSION_dbus ?= "1.0.1"
+PREFERRED_VERSION_dbus-glib ?= "0.71"
+
PREFERRED_VERSION_gstreamer ?= "0.10.6"
PREFERRED_PROVIDER_hostap-conf ?= "hostap-conf"
PREFERRED_PROVIDER_hostap-modules_h2200 ?= "hostap-modules"
PREFERRED_PROVIDER_hostap-modules_hx4700 ?= "hostap-modules"
PREFERRED_VERSION_hostap-modules ?= "0.4.7"
+PREFERRED_VERSION_hostap-utils ?= "0.4.7"
#Down here we put stuff we want to install into machines without polluting conf/machine/ with distro stuff
-# c7x0, akita, spitz, nokia770, h2200, h6300, ipaq-pxa270, simpad
+# c7x0, akita, spitz, nokia770, h2200, h6300, hx4700, simpad
-#### Bootstrap options ####
-
-PCMCIA_MANAGER_c7x0 = "pcmciautils"
-PCMCIA_MANAGER_akita = "pcmciautils"
-PCMCIA_MANAGER_spitz = "pcmciautils"
-PCMCIA_MANAGER_tosa = "pcmciautils"
-PCMCIA_MANAGER_poodle = "pcmciautils"
-PCMCIA_MANAGER_nokia770 = "pcmciautils"
-PCMCIA_MANAGER_h2200 = "pcmciautils"
-PCMCIA_MANAGER_h4000 = "pcmciautils"
-PCMCIA_MANAGER_h6300 = "pcmciautils"
-PCMCIA_MANAGER_ipaq-pxa270 = "pcmciautils"
# add altboot to compatible models, will be replaced with angstrom-bootmanager
#EXTRA_STUFF_append_c7x0 = "altboot"
@@ -157,20 +193,27 @@ PCMCIA_MANAGER_ipaq-pxa270 = "pcmciautils"
#EXTRA_STUFF_append_poodle = "altboot"
#EXTRA_STUFF_append_tosa = "altboot"
-### GPE section ###
-#Install libgtkinput in devices without a keyboard
-GPE_EXTRA_INSTALL_append_ipaq-pxa270 = " libgtkinput"
-GPE_EXTRA_INSTALL_append_h2200 = " libgtkinput"
-GPE_EXTRA_INSTALL_append_h4000 = " libgtkinput"
-GPE_EXTRA_INSTALL_append_h6300 = " libgtkinput"
-GPE_EXTRA_INSTALL_append_simpad = " libgtkinput"
-GPE_EXTRA_INSTALL_append_nokia770 = " libgtkinput"
+# do some task-base stuff here
+
+# We want to ship extra debug utils in the rootfs when doing a debug build
+DEBUG_APPS ?= ""
+DEBUG_APPS += '${@base_conditional("DISTRO_TYPE", "release", "", "tslib-tests tslib-calibrate gdb strace procps",d)}'
+
+#this should go away soon
+EXTRA_STUFF ?= ""
-#As soon as a kill switch is in place we can add it to devices with a keyboard
-#GPE_EXTRA_INSTALL_append_c7x0 = " libgtkinput"
-#GPE_EXTRA_INSTALL_append_tosa = " libgtkinput"
-#GPE_EXTRA_INSTALL_append_akita = " libgtkinput"
-#GPE_EXTRA_INSTALL_append_spitz = " libgtkinput"
+# Angstrom want to ship some extra stuff. This should be moved into task-base eventually
+DISTRO_EXTRA_RDEPENDS = "\
+ update-modules module-init-tools modutils-initscripts \
+ sysvinit initscripts sysvinit-pidof \
+ psplash \
+ netbase dropbear \
+ angstrom-version \
+ ipkg ipkg-collateral \
+ util-linux-mount util-linux-umount \
+ ${EXTRA_STUFF} \
+ ${DEBUG_APPS} \
+ "
diff --git a/meta/conf/distro/include/angstrom.inc b/meta/conf/distro/include/angstrom.inc
index 5ff9e1c942..3bf87abdb6 100644
--- a/meta/conf/distro/include/angstrom.inc
+++ b/meta/conf/distro/include/angstrom.inc
@@ -5,47 +5,47 @@
DISTRO = "angstrom"
DISTRO_NAME = "Angstrom"
+TARGET_VENDOR = "-angstrom"
+MACHINE_TASK_PROVIDER = "task-base"
+
+# Can be "glibc" and "uclibc"
+ANGSTROM_MODE ?= "glibc"
+
+DEPLOY_DIR = "${TMPDIR}/deploy/${ANGSTROM_MODE}"
+require conf/distro/include/angstrom-${ANGSTROM_MODE}.inc
+
#Use this variable in feeds and other parts that need a URI
ANGSTROM_URI = "http://www.angstrom-distribution.org"
#Set the default maintainer to angstrom-dev
-MAINTAINER = "Angstrom Developers <angstrom-dev@linuxtogo.org>"
+MAINTAINER = "Angstrom Developers <angstrom-distro-devel@linuxtogo.org>"
#use ipkg package format with debian style naming
#use multimachine buildrules
-INHERIT += "package_ipk debian multimachine"
+INHERIT += "package_ipk debian multimachine sanity"
#Generate locales on the buildsystem instead of on the target. Speeds up first boot, set to "1" to enable
PREFERRED_PROVIDER_qemu-native = "qemu-native"
ENABLE_BINARY_LOCALE_GENERATION ?= "1"
-
-#Use the ARM EABI when building for an ARM cpu. We can't use overrides
-#here because this breaks all places where ":=" is used.
-#if you want to build using uclibc, specify "-uclibcgnueabi"
-TARGET_VENDOR = "-angstrom"
-TARGET_OS = "linux${@['','-gnueabi'][bb.data.getVar('TARGET_ARCH',d,1)=='arm']}"
-#uclibc (needs gcc 4.1.1 or newer)
-#TARGET_OS = "linux${@['','-uclibcgnueabi'][bb.data.getVar('TARGET_ARCH',d,1)=='arm']}"
-
-#mess with compiler flags to use -Os instead of -O2
-#Please see http://free-electrons.com/doc/embedded_linux_optimizations/img47.html for some more info
-FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os"
-BUILD_OPTIMIZATION = "-Os"
-CXXFLAGS += "-fvisibility-inlines-hidden"
+#qemu doesn't like armv6/eabi/vfp
+ENABLE_BINARY_LOCALE_GENERATION_mx31ads = "0"
#ARM EABI is softfloat by default, but let's make sure :)
-TARGET_FPU_arm = "soft"
+#make it overridable for platforms with FPU, like ep93xx or i.mx31
+TARGET_FPU_arm ?= "soft"
+TARGET_FPU_ixp4xx ?= "soft"
+
-#Always ship these packages
-BOOTSTRAP_EXTRA_RDEPENDS += "angstrom-version coreutils dropbear sysvinit"
+#Make a LE jffs2 image
+SLUGOS_IMAGESEX = "little-endian"
#Name the generated images in a sane way
IMAGE_NAME = "${DISTRO_NAME}-${IMAGE_BASENAME}-${DISTRO_VERSION}-${MACHINE}"
-DEPLOY_DIR_IMAGE = ${DEPLOY_DIR}/images/${MACHINE}
+DEPLOY_DIR_IMAGE = "${DEPLOY_DIR}/images/${MACHINE}"
# Angstrom *always* has some form of release config, so error out if someone thinks he knows better
DISTRO_CHECK := "${@bb.data.getVar("DISTRO_VERSION",d,1) or bb.fatal('Remove this line or set a dummy DISTRO_VERSION if you really want to build an unversioned distro')}"
# We want images supporting the following features (for task-base)
-DISTO_FEATURES = "nfs smbfs ipsec wifi ppp alsa bluetooth ext2 irda pcmcia usbgadget usbhost"
+DISTRO_FEATURES = "nfs smbfs wifi ppp alsa bluetooth ext2 irda pcmcia usbgadget usbhost"
diff --git a/meta/conf/distro/include/maemo-preferred.inc b/meta/conf/distro/include/maemo-preferred.inc
deleted file mode 100644
index 943f244326..0000000000
--- a/meta/conf/distro/include/maemo-preferred.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-PREFERRED_PROVIDER_gconf = "gconf-osso"
-PREFERRED_PROVIDER_tslib = "tslib-maemo"
-PREFERRED_VERSION_dbus = "0.23.1-osso5"
-PREFERRED_VERSION_audiofile = "0.2.6-3osso4"
-PREFERRED_PROVIDER_esd = "osso-esd"
-PREFERRED_VERSION_gtk+ = "2.6.4-1.osso7"
-PREFERRED_VERSION_glib-2.0 = "2.6.4"
-PREFERRED_VERSION_pango = "1.8.1"
-PREFERRED_VERSION_atk = "1.9.0"
-PREFERRED_VERSION_diet-x11 ?= "6.2.1" \ No newline at end of file
diff --git a/meta/conf/distro/include/openzaurus.inc b/meta/conf/distro/include/openzaurus.inc
index 01877956ed..ea408ff221 100644
--- a/meta/conf/distro/include/openzaurus.inc
+++ b/meta/conf/distro/include/openzaurus.inc
@@ -22,4 +22,4 @@ BB_MIN_VERSION = "1.4.4"
INHERIT += "sanity"
# We want images supporting the following features (for task-base)
-DISTO_FEATURES = "nfs smbfs ipsec wifi ppp alsa bluetooth ext2 irda pcmcia usbgadget usbhost"
+DISTRO_FEATURES = "nfs smbfs ipsec wifi ppp alsa bluetooth ext2 irda pcmcia usbgadget usbhost"
diff --git a/meta/conf/distro/include/preferred-gpe-versions-2.7.inc b/meta/conf/distro/include/preferred-gpe-versions-2.7.inc
index 36702025c1..662dfc386f 100644
--- a/meta/conf/distro/include/preferred-gpe-versions-2.7.inc
+++ b/meta/conf/distro/include/preferred-gpe-versions-2.7.inc
@@ -6,8 +6,8 @@
#SRCDATE_minimo=20050401
#set some preferred providers:
-PREFERRED_PROVIDER_gconf=gconf-dbus
-PREFERRED_PROVIDER_gnome-vfs=gnome-vfs-dbus
+PREFERRED_PROVIDER_gconf="gconf-dbus"
+PREFERRED_PROVIDER_gnome-vfs="gnome-vfs-dbus"
#specify versions, as the header says :)
PREFERRED_VERSION_libmatchbox ?= "1.7"
@@ -20,9 +20,9 @@ PREFERRED_VERSION_matchbox-applet-inputmanager ?= "0.6"
PREFERRED_VERSION_atk ?= "1.9.0"
PREFERRED_VERSION_cairo ?= "0.5.2"
PREFERRED_VERSION_glib-2.0 ?= "2.6.4"
+PREFERRED_VERSION_pango ?= "1.8.2"
PREFERRED_VERSION_gtk+ ?= "2.6.10"
PREFERRED_VERSION_gtk-engines ?= "2.6.5"
-PREFERRED_VERSION_pango ?= "1.8.1"
PREFERRED_VERSION_librsvg ?= "2.6.5"
PREFERRED_VERSION_libgpewidget ?= "0.109"
PREFERRED_VERSION_libgpepimc ?= "0.5"
diff --git a/meta/conf/distro/include/preferred-opie-versions.inc b/meta/conf/distro/include/preferred-opie-versions.inc
index 34c1fd498e..d7c5b94f7a 100644
--- a/meta/conf/distro/include/preferred-opie-versions.inc
+++ b/meta/conf/distro/include/preferred-opie-versions.inc
@@ -12,7 +12,7 @@ PREFERRED_PROVIDER_virtual/libqte2 = '${@base_conditional("PALMTOP_USE_MULTITHRE
PREFERRED_PROVIDER_virtual/libqpe1 = "libqpe-opie"
PREFERRED_VERSION_qte-mt = "${QTE_VERSION}"
PREFERRED_VERSION_qte = "${QTE_VERSION}"
-PREFERRED_VERSION_libopie2 = "${OPIE_VERSION}"
+PREFERRED_VERSION_libopie2 ?= "${OPIE_VERSION}"
PREFERRED_VERSION_libopieobex0 = "${OPIE_VERSION}"
PREFERRED_VERSION_libopietooth1 = "${OPIE_VERSION}"
PREFERRED_VERSION_libqpe-opie = "${OPIE_VERSION}"
diff --git a/meta/conf/distro/include/sane-srcdates.inc b/meta/conf/distro/include/sane-srcdates.inc
index 0696ad1909..ffde56224c 100644
--- a/meta/conf/distro/include/sane-srcdates.inc
+++ b/meta/conf/distro/include/sane-srcdates.inc
@@ -5,7 +5,6 @@ SRCDATE_at76c503a-modules ?= "20060814"
SRCDATE_prism54-module ?= "20060814"
# X11 libs, extentions and protos
-SRCDATE_xcalibrate ?= "20060804"
SRCDATE_compositeext ?= "20060814"
SRCDATE_drm ?= "20060814"
SRCDATE_drm-kernel ?= "20060814"
@@ -22,8 +21,10 @@ SRCDATE_xxf86vmext ?= "20060814"
# Matchbox / O-hand
SRCDATE_contacts ?= "20060707"
SRCDATE_dates ?= "20060707"
-SRCDATE_web ?= "20060613"
+SRCDATE_fstests ?= "20061111"
SRCDATE_eds-dbus ?= "20060707"
+SRCDATE_libmatchbox ?= "20060612"
+SRCDATE_libfakekey ?= "20051101"
SRCDATE_matchbox-common ?= "20060612"
SRCDATE_matchbox-config-gtk ?= "20060612"
SRCDATE_matchbox-desktop ?= "20060612"
@@ -33,13 +34,14 @@ SRCDATE_matchbox-panel-manager ?= "20060612"
SRCDATE_matchbox-stroke ?= "20060612"
SRCDATE_matchbox-themes-extra ?= "20060612"
SRCDATE_matchbox-wm ?= "20060612"
-SRCDATE_libmatchbox ?= "20060612"
-SRCDATE_libfakekey ?= "20051101"
+SRCDATE_psplash ?= "20061011"
+SRCDATE_web ?= "20060613"
SRCDATE_zaurusd ?= "20060628"
# GPE
SRCDATE_dasher-gpe ?= "20060814"
SRCDATE_rosetta ?= "20060804"
+SRCDATE_libmimedir ?= "20060804"
# GNOME
SRCDATE_gconf-dbus ?= "20060719"
@@ -54,12 +56,13 @@ SRCDATE_dvbtraffic ?= "20060814"
SRCDATE_dvbtune ?= "20060814"
SRCDATE_fdclock ?= "20060814"
SRCDATE_fltk ?= "20060814"
+SRCDATE_ipatience ?= "20061112"
SRCDATE_ipkg-link ?= "20050930"
SRCDATE_ipkg-link-1 ?= "20050930"
SRCDATE_ipkg-utils ?= "20050930"
SRCDATE_ipkg-utils-native ?= "20050930"
SRCDATE_kaffe-qt ?= "20060814"
-SRCDATE_kbdd ?= "20060814"
+SRCDATE_kbdd ?= "20061019"
SRCDATE_led ?= "20060814"
SRCDATE_linux-input ?= "20060814"
SRCDATE_madwifi-modules ?= "20060814"
@@ -68,7 +71,7 @@ SRCDATE_minimo ?= "20050401"
SRCDATE_mystun-server ?= "20060814"
SRCDATE_olsrd ?= "20060814"
SRCDATE_opencvs ?= "20060814"
-SRCDATE_oprofile ?= "20060214"
+SRCDATE_oprofile ?= "20061011"
SRCDATE_portaudio ?= "20060814"
SRCDATE_putty ?= "20060814"
SRCDATE_python-cairo ?= "20060814"
diff --git a/meta/conf/distro/openzaurus-unstable.conf b/meta/conf/distro/openzaurus-unstable.conf
index 43492944ff..10f00b7604 100644
--- a/meta/conf/distro/openzaurus-unstable.conf
+++ b/meta/conf/distro/openzaurus-unstable.conf
@@ -8,8 +8,7 @@ DISTRO_VERSION = ".dev-snapshot-${DATE}"
CVS_TARBALL_STASH = "\
http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/sources/ \
-http://www.oesources.org/source/current/"
-
+"
require conf/distro/include/sane-srcdates.inc
require conf/distro/include/openzaurus.inc
@@ -34,7 +33,7 @@ SRCDATE ?= "20060701"
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"
PREFERRED_PROVIDER_hostap-conf = "hostap-conf"
PREFERRED_PROVIDER_task-bootstrap = "task-bootstrap"
-PREFERRED_PROVIDER_tslib ?= tslib
+PREFERRED_PROVIDER_tslib ?= "tslib"
KERNEL_CONSOLE = "ttyS0"
#DEBUG_OPTIMIZATION = "-O -g3"
@@ -52,8 +51,13 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
-PREFERRED_VERSION_binutils-cross = "2.15.94.0.1"
-PREFERRED_VERSION_binutils = "2.15.94.0.1"
+PREFERRED_VERSION_binutils-cross = "2.16"
+PREFERRED_VERSION_binutils = "2.16"
+
+PREFERRED_VERSION_glibc = "2.3.5+cvs20050627"
+PREFERRED_VERSION_gcc = "3.4.4"
+PREFERRED_VERSION_gcc-cross = "3.4.4"
+PREFERRED_VERSION_gcc-cross-initial = "3.4.4"
#
# Opie
diff --git a/meta/conf/distro/poky.conf b/meta/conf/distro/poky.conf
index bbf8d940ad..82edf8d8fa 100644
--- a/meta/conf/distro/poky.conf
+++ b/meta/conf/distro/poky.conf
@@ -13,10 +13,11 @@ PACKAGE_CLASSES ?= "package_ipk"
INHERIT += " ${PACKAGE_CLASSES} debian multimachine poky devshell "
# For some reason, this doesn't work
# TARGET_OS ?= "linux"
+# TARGET_VENDOR = "-poky"
TARGET_OS = "linux"
TARGET_FPU_arm ?= "soft"
TARGET_FPU_armeb ?= "soft"
-IMAGE_ROOTFS_SIZE_ext2 ?= 131072
+IMAGE_ROOTFS_SIZE_ext2 ?= "131072"
PARALLEL_INSTALL_MODULES = "1"
@@ -50,8 +51,8 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
# Libc/uclibc:
#fix some iconv issues, needs to be adjusted when doing uclibc builds
-PREFERRED_PROVIDER_virtual/libiconv ?= glibc
-PREFERRED_PROVIDER_virtual/libintl ?= glibc
+PREFERRED_PROVIDER_virtual/libiconv ?= "glibc"
+PREFERRED_PROVIDER_virtual/libintl ?= "glibc"
# Virtuals:
PREFERRED_PROVIDER_virtual/db ?= "db"
@@ -62,9 +63,9 @@ PREFERRED_PROVIDER_virtual/update-alternatives-native ?= update-alternatives-cwo
# Others:
PREFERRED_PROVIDER_libx11 ?= "diet-x11"
-PREFERRED_PROVIDER_gconf ?= gconf-dbus
-PREFERRED_PROVIDER_gnome-vfs ?= gnome-vfs-dbus
-PREFERRED_PROVIDER_tslib ?= tslib
+PREFERRED_PROVIDER_gconf ?= "gconf-dbus"
+PREFERRED_PROVIDER_gnome-vfs ?= "gnome-vfs-dbus"
+PREFERRED_PROVIDER_tslib ?= "tslib"
#
diff --git a/meta/conf/documentation.conf b/meta/conf/documentation.conf
index 699ac216eb..62622ea255 100644
--- a/meta/conf/documentation.conf
+++ b/meta/conf/documentation.conf
@@ -1,6 +1,6 @@
# this file holds documentation for known keys, possible values and
# their meaning. Please update, correct and extend this documentation.
-# Mail your changes to oe@handhelds.org
+# Mail your changes to openembedded-devel@openembedded.org
# conf/bitbake.conf
PREFERRED_VERSION[doc] = 'Normally use it as PREFERRED_VERSION_package-name = "" to set the preferred \
@@ -57,7 +57,7 @@ PRIORITY[doc] = "Importance of package, default values are 'optional' or 'needed
DESCRIPTION[doc] = "A small description of the package."
LICENSE[doc] = "The license of the resulting package e.g. GPL"
AUTHOR[doc] = "The author of the files installed."
-MAINTAINER[doc] = "Maintainer of the .bb file and the resulting package."
+MAINTAINER[doc] = "Distributions can put this in their .conf file to add their contact information into packages, this is not valid inside recipes"
HOMEPAGE[doc] = "Homepage of the package e.g. http://www.project.net."
diff --git a/meta/conf/machine/akita.conf b/meta/conf/machine/akita.conf
index 0b0caebb3c..27695be4bb 100644
--- a/meta/conf/machine/akita.conf
+++ b/meta/conf/machine/akita.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Sharp Zaurus SL-C1000 device
include conf/machine/include/zaurus-clamshell.conf
-include conf/machine/include/zaurus-clamshell-2.6.conf
+include conf/machine/include/zaurus-2.6.conf
PACKAGE_EXTRA_ARCHS += "iwmmxt"
IMAGE_FSTYPES ?= "jffs2"
diff --git a/meta/conf/machine/c7x0.conf b/meta/conf/machine/c7x0.conf
index 4b1d8edb80..893378f569 100644
--- a/meta/conf/machine/c7x0.conf
+++ b/meta/conf/machine/c7x0.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Sharp Zaurus SL-C700, Sharp Zaurus SL-C750, Sharp Zaurus SL-C760, Sharp Zaurus SL-C860 devices
include conf/machine/include/zaurus-clamshell.conf
-include conf/machine/include/zaurus-clamshell-2.6.conf
+include conf/machine/include/zaurus-2.6.conf
IMAGE_FSTYPES ?= "jffs2"
diff --git a/meta/conf/machine/include/ixp4xx.conf b/meta/conf/machine/include/ixp4xx.conf
index e545bbc1c0..190ebe1c8c 100644
--- a/meta/conf/machine/include/ixp4xx.conf
+++ b/meta/conf/machine/include/ixp4xx.conf
@@ -141,28 +141,12 @@ PACKAGE_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
bb.data.getVar('THUMB_INTERWORK', d, 1) == 'yes')} \
${MACHINE_ARCH} ${MACHINE}${ARCH_BYTE_SEX}"
-# PACKAGE_ARCH_LIST [not used]
+# IPKG_ARCH_LIST [not used]
# This is used to override the ipkgarchs settings in rootfs_ipk.bbclass, allowing
# the removal of the raw "${MACHINE}" from the end of the list. ${MACHINE} and
# ixp4xx are included at the start (lower priority) as the non-byte-sex specific
# versions.
-PACKAGE_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${PACKAGE_EXTRA_ARCHS}"
-
-#-------------------------------------------------------------------------------
-# Package versions
-#-------------------------------------------------------------------------------
-# Warning: these are shared across the different machine and distro
-# configurations but can be overridden therein if required.
-SRCDATE_ipkg-utils ?= "20060106"
-SRCDATE_ipkg-utils-native ?= "20060106"
-SRCDATE_ipkg-link ?= "20060106"
-SRCDATE_irssi ?= "20050930"
-
-CVS_TARBALL_STASH = "http://sources.nslu2-linux.org/sources/"
-INHERIT += "nslu2-mirrors"
-
-PREFERRED_VERSION_ipkg ?= "0.99.154"
-PREFERRED_VERSION_ipkg-native ?= "0.99.154"
+IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${PACKAGE_EXTRA_ARCHS}"
#-------------------------------------------------------------------------------
# Board defaults
diff --git a/meta/conf/machine/include/poodle-2.6.conf b/meta/conf/machine/include/poodle-2.6.conf
index eff0ad4c7c..01a06b7c27 100644
--- a/meta/conf/machine/include/poodle-2.6.conf
+++ b/meta/conf/machine/include/poodle-2.6.conf
@@ -1 +1 @@
-require conf/machine/include/zaurus-clamshell-2.6.conf
+require conf/machine/include/zaurus-2.6.conf
diff --git a/meta/conf/machine/include/qemu.conf b/meta/conf/machine/include/qemu.conf
index c896c38f57..83ddf24b87 100644
--- a/meta/conf/machine/include/qemu.conf
+++ b/meta/conf/machine/include/qemu.conf
@@ -1,6 +1,7 @@
PCMCIA_MANAGER = "pcmciautils"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
GUI_MACHINE_CLASS = "bigscreen"
+GPE_EXTRA_INSTALL += "gaim sylpheed"
MACHINE_FEATURES = "kernel26 apm alsa pcmcia bluetooth irda usbgadget"
diff --git a/meta/conf/machine/include/tosa-2.6.conf b/meta/conf/machine/include/tosa-2.6.conf
index 6831b0ea91..f3591b4b75 100644
--- a/meta/conf/machine/include/tosa-2.6.conf
+++ b/meta/conf/machine/include/tosa-2.6.conf
@@ -1,4 +1,4 @@
-include conf/machine/include/zaurus-clamshell-2.6.conf
+include conf/machine/include/zaurus-2.6.conf
# wlan-ng Modules
MACHINE_EXTRA_RDEPENDS += "wlan-ng-modules-usb"
diff --git a/meta/conf/machine/include/tune-arm920t.conf b/meta/conf/machine/include/tune-arm920t.conf
index 992f1923c6..373bf46727 100644
--- a/meta/conf/machine/include/tune-arm920t.conf
+++ b/meta/conf/machine/include/tune-arm920t.conf
@@ -1,3 +1,3 @@
PACKAGE_ARCH = "armv4t"
-TARGET_CC_ARCH = "-march=armv4t -mtune=arm920t -mcpu=arm920t"
+TARGET_CC_ARCH = "-march=armv4t -mtune=arm920t"
diff --git a/meta/conf/machine/include/tune-arm9tdmi.conf b/meta/conf/machine/include/tune-arm9tdmi.conf
index cfc3bad1c1..d097b07739 100644
--- a/meta/conf/machine/include/tune-arm9tdmi.conf
+++ b/meta/conf/machine/include/tune-arm9tdmi.conf
@@ -1 +1,2 @@
+PACKAGE_ARCH = "armv4t"
TARGET_CC_ARCH = "-mcpu=arm9tdmi -mtune=arm9tdmi"
diff --git a/meta/conf/machine/include/tune-iwmmxt.conf b/meta/conf/machine/include/tune-iwmmxt.conf
index f9c8e7f5cf..8376faca74 100644
--- a/meta/conf/machine/include/tune-iwmmxt.conf
+++ b/meta/conf/machine/include/tune-iwmmxt.conf
@@ -1,6 +1,6 @@
# Configurations for the Intel PXA27x Appications Processor Family.
# Please use tune-xscale for PXA255/PXA26x based processors.
-PACKAGE_EXTRA_ARCHS += "iwmmxt"
TARGET_CC_ARCH = "-march=iwmmxt -mcpu=iwmmxt -mtune=iwmmxt"
PACKAGE_ARCH = "iwmmxt"
+PACKAGE_EXTRA_ARCHS += "iwmmxt"
diff --git a/meta/conf/machine/include/zaurus-clamshell-2.6.conf b/meta/conf/machine/include/zaurus-2.6.conf
index e0a9e38e91..ce9b44c9fe 100644
--- a/meta/conf/machine/include/zaurus-clamshell-2.6.conf
+++ b/meta/conf/machine/include/zaurus-2.6.conf
@@ -6,10 +6,10 @@ PREFERRED_VERSION_wpa_supplicant = "0.4.7"
PCMCIA_MANAGER ?= "pcmciautils"
-MACHINE_FEATURES = "kernel26 apm alsa pcmcia bluetooth irda usbgadget"
-MACHINE_FEATURES_akita = "kernel26 apm alsa pcmcia bluetooth irda usbgadget usbhost"
-MACHINE_FEATURES_spitz = "kernel26 apm alsa pcmcia bluetooth irda usbgadget usbhost ext2"
-
+MACHINE_FEATURES = "kernel26 apm alsa pcmcia irda usbgadget keyboard touchscreen"
+MACHINE_FEATURES_append_tosa = " usbhost usbwlanng "
+MACHINE_FEATURES_append_akita = " usbhost "
+MACHINE_FEATURES_append_spitz = " usbhost ext2 "
MACHINE_EXTRA_RDEPENDS = "zaurusd"
MACHINE_EXTRA_RRECOMMENDS_c7x0 = "kernel-module-snd-soc-corgi"
@@ -17,4 +17,4 @@ MACHINE_EXTRA_RRECOMMENDS_akita = "kernel-module-snd-soc-spitz"
MACHINE_EXTRA_RRECOMMENDS_spitz = "kernel-module-snd-soc-spitz"
MACHINE_EXTRA_RRECOMMENDS_poodle = "kernel-module-snd-soc-poodle"
-MACHINE_TASK_PROVIDER = "task-base" \ No newline at end of file
+MACHINE_TASK_PROVIDER = "task-base"
diff --git a/meta/conf/machine/nokia770.conf b/meta/conf/machine/nokia770.conf
index 2e22771e4a..6bde574d02 100644
--- a/meta/conf/machine/nokia770.conf
+++ b/meta/conf/machine/nokia770.conf
@@ -2,7 +2,7 @@
#@NAME: Nokia 770 internet tablet
#@DESCRIPTION: Machine configuration for the Nokia 770, an omap 1710 based tablet
TARGET_ARCH = "arm"
-PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-omap"
PREFERRED_PROVIDER_virtual/bootloader = ""
@@ -33,4 +33,4 @@ ROOTFS_POSTPROCESS_COMMAND += " remove_init_link; "
MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget usbhost"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "nokia770-init"
-MACHINE_TASK_PROVIDER = "task-base" \ No newline at end of file
+MACHINE_TASK_PROVIDER = "task-base"
diff --git a/meta/conf/machine/spitz.conf b/meta/conf/machine/spitz.conf
index cf2c5f3f4f..2c4e10935e 100644
--- a/meta/conf/machine/spitz.conf
+++ b/meta/conf/machine/spitz.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Sharp Zaurus SL-C3000 device
include conf/machine/include/zaurus-clamshell.conf
-include conf/machine/include/zaurus-clamshell-2.6.conf
+include conf/machine/include/zaurus-2.6.conf
PIVOTBOOT_EXTRA_RDEPENDS += "pivotinit ${PCMCIA_MANAGER}"
diff --git a/meta/conf/sanity.conf b/meta/conf/sanity.conf
index 5a6e3defb6..58313f27ca 100644
--- a/meta/conf/sanity.conf
+++ b/meta/conf/sanity.conf
@@ -3,6 +3,6 @@
# See sanity.bbclass
#
# Expert users can confirm their sanity with "touch conf/sanity.conf"
-BB_MIN_VERSION = "1.4.3"
+BB_MIN_VERSION = "1.6.2"
INHERIT += "sanity"