summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-08-25 19:56:57 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-29 14:04:42 +0100
commit8bb0237a74c2b66d0d0f19e600a5fb39df67894f (patch)
treeec27ed75d4069785f404fedcedef7512c8ddfac9
parentf4ba98ed3c866ec3db90404f894d5aeaa5d79dfd (diff)
downloadmeta-yocto-8bb0237a74c2b66d0d0f19e600a5fb39df67894f.tar.gz
meta-yocto-8bb0237a74c2b66d0d0f19e600a5fb39df67894f.tar.bz2
meta-yocto-8bb0237a74c2b66d0d0f19e600a5fb39df67894f.zip
Remove LSB support bits
LSB as a standard isn't current and isn't well suited to embedded anyway. Its putting artifical constraints on the system and with modern layer technology, would now be better off as its own layer. As such its time to split it out. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-poky/conf/distro/include/poky-distro-alt-test-config.inc2
-rw-r--r--meta-poky/conf/distro/poky-tiny.conf3
-rw-r--r--meta-poky/conf/local.conf.sample.extended2
3 files changed, 2 insertions, 5 deletions
diff --git a/meta-poky/conf/distro/include/poky-distro-alt-test-config.inc b/meta-poky/conf/distro/include/poky-distro-alt-test-config.inc
index 081584f..dff5804 100644
--- a/meta-poky/conf/distro/include/poky-distro-alt-test-config.inc
+++ b/meta-poky/conf/distro/include/poky-distro-alt-test-config.inc
@@ -1,2 +1,2 @@
DISTRO_FEATURES_append = " pam"
-PREFERRED_VERSION_linux-yocto_linuxstdbase ?= "4.19%"
+PREFERRED_VERSION_linux-yocto ?= "4.19%"
diff --git a/meta-poky/conf/distro/poky-tiny.conf b/meta-poky/conf/distro/poky-tiny.conf
index 1f8b6e8..8236b6f 100644
--- a/meta-poky/conf/distro/poky-tiny.conf
+++ b/meta-poky/conf/distro/poky-tiny.conf
@@ -117,9 +117,6 @@ PNBLACKLIST[build-appliance-image] = "not buildable with poky-tiny"
PNBLACKLIST[core-image-base] = "not buildable with poky-tiny"
PNBLACKLIST[core-image-clutter] = "not buildable with poky-tiny"
PNBLACKLIST[core-image-full-cmdline] = "not buildable with poky-tiny"
-PNBLACKLIST[core-image-lsb] = "not buildable with poky-tiny"
-PNBLACKLIST[core-image-lsb-dev] = "not buildable with poky-tiny"
-PNBLACKLIST[core-image-lsb-sdk] = "not buildable with poky-tiny"
PNBLACKLIST[core-image-rt] = "not buildable with poky-tiny"
PNBLACKLIST[core-image-rt-sdk] = "not buildable with poky-tiny"
PNBLACKLIST[core-image-sato] = "not buildable with poky-tiny"
diff --git a/meta-poky/conf/local.conf.sample.extended b/meta-poky/conf/local.conf.sample.extended
index 77e8be2..dc92a16 100644
--- a/meta-poky/conf/local.conf.sample.extended
+++ b/meta-poky/conf/local.conf.sample.extended
@@ -270,7 +270,7 @@ DISTRO_FEATURES_remove = "x11"
#
# By including the security_flags include file you enable flags
# to the compiler and linker that cause them to generate more secure
-# code, this is enabled by default in the poky-lsb distro.
+# code.
# This does affect compile speed slightly.
#
# Use the following line to enable the security compiler and linker flags to your build